Skip to end of metadata
Go to start of metadata

Introduction

ParaView is a general data analysis and visualization application and is available on all the Shared Research Computing Systems. This document describes some of many different ways to run ParaView on the clusters.

Running the GUI on GPU nodes using the Visualization Portal

The Rice Visualization Portal provides an easy way to run a remote desktop on the DAVinCI cluster. This method does not require a local installation of ParaView, just a Java plugin in your browser or a VNC client. This is a good approach if your data is located on DAVinCI and will run on a single node.

  1. Log into the Visualization Portal and select Paraview GUI from the panel on the left
  2. Set the screen resolution and ParaView version from the drop down menus and click Submit
  3. A remote desktop session should launch within a few seconds. If your session disconnects for any reason, simply log back into the portal, select My Sessions from the top menu and reconnect to your running session. Make sure to exit ParaView when you are done, not just the remote desktop client.

Tuning Network Performance

Depending on the remote desktop client you can adjust the connections settings to reduce load on the network when you have a limited bandwidth connection to the cluster. If your client supports the "tight" encoding, reducing the image quality will improve interactivity.

 

Running pvserver on GPU nodes using the Visualization Portal

The Rice Visualization Portal can also be used to run batch jobs on the clusters. In this case the pvserver application can be run in parallel on multiple nodes and multiple GPUs. This method requires ParaView to be installed locally on your workstation or laptop and is useful if your data is located on DAVinCI and is too large to run on a single machine.

  1. Log into the Visualization Portal and select Paraview Service from the panel on the left
  2. Set the ParaView version and processor counts from the drop down menus and click Submit
  3. After a few seconds you should see some text containing a connection URL similar to this: cs://gpu-002.davinci.rcsg.rice.edu:11111

  4. On your local machine, open a terminal window and launch ParaView from the command line with the -url=cs://gpu-002.davinci.rcsg.rice.edu:11111 flag and go to step 9
  5. Or, start ParaView, go to File > Connect and click the Add Servers button
  6. Fill in a name, choose Client/Server in the drop down list, enter the host name from your URL, and fill in the port number. In our example it would look something like this:
    paraview-configuration-image
    click Configure
  7. Select Manual in the drop down list and click Save
  8. Now select your newly created server configuration and click the Connect button
  9. The local ParaView is now connected to the remote pvserver. When you are finished, select File > Disconnect from the menu

Portal Timeout

Sometimes the portal will timeout waiting for the server URL, when this happens it will give you an error message. Select My Data from the top menu and click on your pvserver job. In the Data panel you will see a link named pvserver.out.txt, follow the link and you will see your URL.

Tuning Network Performance

In the Edit > Settings... dialog window, on the Render View > Server panel there are several parameters to control the network behavior between the server and client. In particular, there is a drop down list of presets. For the best performance, choose the preset that closest matches your connection.

Running pvserver using the Server Connect GUI in ParaView

ParaView provides its own support for launching and managing connections to pvservers. In order to use this interface you will need to have ParaView installed on your local laptop or workstation. This method is useful if you do not have a Visualization Portal account, your data is located on a cluster other than DAVinCI, or your data is on DAVinCI but it is too large for the GPU nodes.

Adding configurations for the Shared Research Computing Systems

  1. Go to the File > Connect menu and click on the Fetch Servers button in the dialog window

  2. In the Fetch Server Configuration window,  click the Edit Sources button

  3. Add a URL for the Rice visualization server as shown:

    paraview-configuration-image

    and then click Save

  4. Select any server configurations you would like to use and the click the Import Selected button

Running remote servers

  1. Go to the File > Connect menu and in the dialog window, select the cluster you want to run on and click Connect

  2. Fill out the fields in the Start dialog window, make sure the node, ppn, and walltime values match the queue you've chosen. For example, on DAVinCI it may look something like this:

    paraview-configuration-image

    Click OK

  3. At this point a terminal widow will open reporting that your job has been submitted. When the jobs starts running it will automatically connect back to your ParaView GUI. Depending on the how busy the cluster is, it may take anywhere from a couple of seconds to several hours for your job to start, during this time, do not close the terminal window

  4. When you have finish with the remote server, select File > Disconnect from the menu and close the terminal window

Tuning Network Performance

In the Edit > Settings... dialog window, on the Render View > Server panel there are several parameters to control the network behavior between the server and client. In particular, there is a drop down list of presets. For the best performance, choose the preset that closest matches your connection.