Skip to end of metadata
Go to start of metadata

Introduction

VisIt is a general data analysis and visualization application and is available on all the Shared Research Computing Systems. This document describes some of many different ways to run VisIt on the clusters.

Running the GUI on GPU nodes using the Visualization Portal

The Rice Visualization Portal provides an easy way to run a remote desktop on the DAVinCI cluster. This method does not require a local installation of VisIt, just a Java plugin in your browser or a VNC client. This is a good approach if your data is located on DAVinCI and will run on a single node.

  1. Log into the Visualization Portal and select VisIt from the panel on the left
  2. Set the screen resolution and VisIt version from the drop down menus and click Submit
  3. A remote desktop session should launch within a few seconds. If your session disconnects for any reason, simply log back into the portal, select My Sessions from the top menu and reconnect to your running session. Make sure to exit VisIt when you are done, not just the remote desktop client.

Running VisIt Client-Server

VisIt provides its own support for launching and managing connections to remote compute resources. In order to use this interface you will need to have VisIt installed on your local laptop or workstation. This method is useful if you do not have a Visualization Portal account, your data is located on a cluster other than DAVinCI, or your data is on DAVinCI but it is too large for the GPU nodes.

Adding configurations for the Shared Research Computing Systems

  1. If the local machine is running Windows, download rice_host.zip and place the included XML files in the folder My Documents\VisIt\hosts. For Mac or Linux systems, place the contents of rice_host.tgz in .visit/hosts in your home directory.

  2. Go to the Options > Host Profiles menu and make sure the Account Username field matches your Rice netid for each host you plan on using. After updating your username, you can select Options > Save Settings to make your changes permanent.

visit-configuration-image1

Running remote servers

  1. Go to the File > Open file... menu or select the Open button under Sources.
  2. In the File Open dialog choose the remote resource from the Host drop down list. If a password dialog box comes up, use your Rice netid password.
  3. Select a file in the browser and click OK.
  4. In the Options dialog choose the job queue, node count, and total number of processors. For example, on BlueBioU it may look something like this:
    visit-configuration-image2
    Click OK
  5. A dialog window will appear indicating that VisIt is waiting for the compute engine to launch. Depending on your job properties and how busy the cluster is, it may take anywhere from a couple of seconds to several hours for the job to start.

Job Options

 The VisIt GUI will not prevent you from requesting job resources that will not be filled by the scheduler. Make sure to keep the nodes and processor requests within the limits of the selected queue.