We are experiencing issues with Banner Forms and the Java client.  The error message includes the following reason..."Your security settings have blocked an application signed with an expired or not-yet-valid certificate from running." 

If you are experiencing this error, please contact the Help Desk at helpdesk@rice.edu or at #4357 for assistance.